#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<i>([\s\S]*?)<\/i>\s*\(([0-9]*)\)$"
Local $sString = "<i>Alien - Resurrection </i> (1997)" & @CRLF & _
"<i>Alien - Resurrection </i>(1997)" & @CRLF & _
"<i>Alien - Resurrection </i>" & @CRLF & _
"(1997)" & @CRLF & _
"<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")