$re = '/^<i>([\s\S]*?)<\/i>\s*\(([0-9]*)\)$/m';
$str = '<i>Alien - Resurrection </i> (1997)
<i>Alien - Resurrection </i>(1997)
<i>Alien - Resurrection </i>
(1997)
<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);