package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<i>([\s\S]*?)<\/i>\s*\(([0-9]*)\)$`)
var str = `<i>Alien - Resurrection </i> (1997)
<i>Alien - Resurrection </i>(1997)
<i>Alien - Resurrection </i>
(1997)
<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}