re = /^<i>([\s\S]*?)<\/i>\s*\(([0-9]*)\)$/m
str = '<i>Alien - Resurrection </i> (1997)
<i>Alien - Resurrection </i>(1997)
<i>Alien - Resurrection </i>
(1997)
<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end