use strict;
my $str = '<i>Alien - Resurrection </i> (1997)
<i>Alien - Resurrection </i>(1997)
<i>Alien - Resurrection </i>
(1997)
<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)';
my $regex = qr/^<i>([\s\S]*?)<\/i>\s*\(([0-9]*)\)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}