import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<i>([\\s\\S]*?)<\\/i>\\s*\\(([0-9]*)\\)$";
final String string = "<i>Alien - Resurrection </i> (1997)\n"
+ "<i>Alien - Resurrection </i>(1997)\n"
+ "<i>Alien - Resurrection </i>\n"
+ "(1997)\n"
+ "<li> Alien -Resurrection </i> bla bla bla <i> Alien the first one </i> (1991)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}