using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]:\\|\\(.))((.)+\\)?$";
string input = @"C
C:
C:/
C://
C:\
C:\\
C:\Documents\Newsletters\Summer2018.pdf
\Program Files\Custom Utilities\StringFinder.exe
2018\January.xlsx
..\Publications\TravelBrochure.pdf
C:\Projects\apilibrary\apilibrary.sln
C:Projects\apilibrary\apilibrary.sln
\\system07\C$\
\\Server2\Share\Test\Foo.txt
\\.\C:\Test\Foo.txt
\\?\C:\Test\Foo.txt
C:\utilities\filecompare\
c:\utilities\filecompare\
\\Server\Share
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}