import Foundation
let pattern = #"^([a-zA-Z]:\\|\\(.))((.)+\\)?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C
C:
C:/
C://
C:\
C:\\
C:\Documents\Newsletters\Summer2018.pdf
\Program Files\Custom Utilities\StringFinder.exe
2018\January.xlsx
..\Publications\TravelBrochure.pdf
C:\Projects\apilibrary\apilibrary.sln
C:Projects\apilibrary\apilibrary.sln
\\system07\C$\
\\Server2\Share\Test\Foo.txt
\\.\C:\Test\Foo.txt
\\?\C:\Test\Foo.txt
C:\utilities\filecompare\
c:\utilities\filecompare\
\\Server\Share
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}