use strict;
my $str = 'C
C:
C:/
C://
C:\\
C:\\\\
C:\\Documents\\Newsletters\\Summer2018.pdf
\\Program Files\\Custom Utilities\\StringFinder.exe
2018\\January.xlsx
..\\Publications\\TravelBrochure.pdf
C:\\Projects\\apilibrary\\apilibrary.sln
C:Projects\\apilibrary\\apilibrary.sln
\\\\system07\\C$\\
\\\\Server2\\Share\\Test\\Foo.txt
\\\\.\\C:\\Test\\Foo.txt
\\\\?\\C:\\Test\\Foo.txt
C:\\utilities\\filecompare\\
c:\\utilities\\filecompare\\
\\\\Server\\Share
';
my $regex = qr/^([a-zA-Z]:\\|\\(.))((.)+\\)?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}