// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-zA-Z]:\\|\\(.))((.)+\\)?$").unwrap();
let string = "C
C:
C:/
C://
C:\\
C:\\\\
C:\\Documents\\Newsletters\\Summer2018.pdf
\\Program Files\\Custom Utilities\\StringFinder.exe
2018\\January.xlsx
..\\Publications\\TravelBrochure.pdf
C:\\Projects\\apilibrary\\apilibrary.sln
C:Projects\\apilibrary\\apilibrary.sln
\\\\system07\\C$\\
\\\\Server2\\Share\\Test\\Foo.txt
\\\\.\\C:\\Test\\Foo.txt
\\\\?\\C:\\Test\\Foo.txt
C:\\utilities\\filecompare\\
c:\\utilities\\filecompare\\
\\\\Server\\Share
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}