import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]:\\\\|\\\\(.))((.)+\\\\)?$";
final String string = "C\n"
+ "C:\n"
+ "C:/\n"
+ "C://\n"
+ "C:\\\n"
+ "C:\\\\\n"
+ "C:\\Documents\\Newsletters\\Summer2018.pdf\n"
+ "\\Program Files\\Custom Utilities\\StringFinder.exe\n"
+ "2018\\January.xlsx\n"
+ "..\\Publications\\TravelBrochure.pdf\n"
+ "C:\\Projects\\apilibrary\\apilibrary.sln\n"
+ "C:Projects\\apilibrary\\apilibrary.sln\n"
+ "\\\\system07\\C$\\\n"
+ "\\\\Server2\\Share\\Test\\Foo.txt\n"
+ "\\\\.\\C:\\Test\\Foo.txt\n"
+ "\\\\?\\C:\\Test\\Foo.txt\n"
+ "C:\\utilities\\filecompare\\\n"
+ "c:\\utilities\\filecompare\\\n"
+ "\\\\Server\\Share\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}