const regex = /^([a-zA-Z]:\\|\\(.))((.)+\\)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]:\\\\|\\\\(.))((.)+\\\\)?$', '')
const str = `C
C:
C:/
C://
C:\\
C:\\\\
C:\\Documents\\Newsletters\\Summer2018.pdf
\\Program Files\\Custom Utilities\\StringFinder.exe
2018\\January.xlsx
..\\Publications\\TravelBrochure.pdf
C:\\Projects\\apilibrary\\apilibrary.sln
C:Projects\\apilibrary\\apilibrary.sln
\\\\system07\\C\$\\
\\\\Server2\\Share\\Test\\Foo.txt
\\\\.\\C:\\Test\\Foo.txt
\\\\?\\C:\\Test\\Foo.txt
C:\\utilities\\filecompare\\
c:\\utilities\\filecompare\\
\\\\Server\\Share
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}