using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Bob[\s._-]1[\s._-]";
string input = @"Hello, I'm Bob 1
Hello, I'm Bob 11
Hey, it's Bob-1 over there
Hey, it's Bob - 1 over there
Bob.1
Bob_1 rules!
Bob1
Bob 1";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}