use strict;
my $str = 'Hello, I\'m Bob 1
Hello, I\'m Bob 11
Hey, it\'s Bob-1 over there
Hey, it\'s Bob - 1 over there
Bob.1
Bob_1 rules!
Bob1
Bob 1';
my $regex = qr/Bob[\s._-]1[\s._-]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}