re = /Bob[\s._-]1[\s._-]/i
str = 'Hello, I\'m Bob 1
Hello, I\'m Bob 11
Hey, it\'s Bob-1 over there
Hey, it\'s Bob - 1 over there
Bob.1
Bob_1 rules!
Bob1
Bob 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end