// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Bob[\s._-]1[\s._-]").unwrap();
let string = "Hello, I'm Bob 1
Hello, I'm Bob 11
Hey, it's Bob-1 over there
Hey, it's Bob - 1 over there
Bob.1
Bob_1 rules!
Bob1
Bob 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}