import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Bob[\\s._-]1[\\s._-]";
final String string = "Hello, I'm Bob 1\n"
+ "Hello, I'm Bob 11\n"
+ "Hey, it's Bob-1 over there\n"
+ "Hey, it's Bob - 1 over there\n"
+ "Bob.1\n"
+ "Bob_1 rules!\n"
+ "Bob1\n"
+ "Bob 1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}