# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\s|\t)*\\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?/\5/;t' <<< "//----------------------------
// COMMENT
//----------------------------
"