$re = '/((\s|\t)*\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?/';
$str = '//----------------------------
// COMMENT
//----------------------------
';
$subst = "\5";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;