#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\s|\t)*\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?"
Local $sString = "//----------------------------" & @CRLF & _
"// COMMENT" & @CRLF & _
"//----------------------------" & @CRLF & _
""
Local $sSubst = "\5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)