using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\s|\t)*\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?";
string substitution = @"\5";
string input = @"//----------------------------
// COMMENT
//----------------------------
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}