use strict;
my $str = '//----------------------------
// COMMENT
//----------------------------
';
my $regex = qr/((\s|\t)*\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?/p;
my $subst = '\\5';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";