re = /((\s|\t)*\/{2,})(.*[-]+)(\r?\n)((\1(.*)\4?)+)\4\1\3\4?/
str = '//----------------------------
// COMMENT
//----------------------------
'
subst = '\\5'
result = str.sub(re, subst)
# Print the result of the substitution
puts result