use strict;
my $str = '>atttaggacctta\\nattgtcggta\\n>ccattnnnn\\ncccatt\\n>ttaggccta';
my $regex = qr/(?<=>)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";