import re
regex = re.compile(r"(?<=>)")
test_str = ">atttaggacctta\\nattgtcggta\\n>ccattnnnn\\ncccatt\\n>ttaggccta"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)