package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`dc\Dc(?P<name1>\d+)\D`)
var str = `column row 1
dc(ID) 273
dc(SBC) 2
dc(TGID) 273
dc(TGN) 434
dc(beginTime) 2
dc(c1907466966) 29
dc(c1907466967) 38
dc(c1907466968) 32
dc(c1907466969) 15
dc(c1907466970) 32
dc(c1907466971) 34
dc(c1907466972) 5
dc(c1907466973) 28
dc(c1907466974) 36
dc(c1907466975) 33
dc(c1907466976) 38
dc(c1907466977)
(?P<subname>\w+_(?<=_).*?(?=\.)).*" |`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}