import Foundation
let pattern = #"dc\Dc(?P<name1>\d+)\D"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
column row 1
dc(ID) 273
dc(SBC) 2
dc(TGID) 273
dc(TGN) 434
dc(beginTime) 2
dc(c1907466966) 29
dc(c1907466967) 38
dc(c1907466968) 32
dc(c1907466969) 15
dc(c1907466970) 32
dc(c1907466971) 34
dc(c1907466972) 5
dc(c1907466973) 28
dc(c1907466974) 36
dc(c1907466975) 33
dc(c1907466976) 38
dc(c1907466977)
(?P<subname>\w+_(?<=_).*?(?=\.)).*" |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)