import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dc\\Dc(?P<name1>\\d+)\\D";
final String string = "column row 1\n"
+ "dc(ID) 273\n"
+ "dc(SBC) 2\n"
+ "dc(TGID) 273\n"
+ "dc(TGN) 434\n"
+ "dc(beginTime) 2\n"
+ "dc(c1907466966) 29\n"
+ "dc(c1907466967) 38\n"
+ "dc(c1907466968) 32\n"
+ "dc(c1907466969) 15\n"
+ "dc(c1907466970) 32\n"
+ "dc(c1907466971) 34\n"
+ "dc(c1907466972) 5\n"
+ "dc(c1907466973) 28\n"
+ "dc(c1907466974) 36\n"
+ "dc(c1907466975) 33\n"
+ "dc(c1907466976) 38\n"
+ "dc(c1907466977)\n\n\n"
+ "(?P<subname>\\w+_(?<=_).*?(?=\\.)).*\" |";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}