const regex = /dc\Dc(?P<name1>\d+)\D/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('dc\\Dc(?P<name1>\\d+)\\D', 'g')
const str = `column row 1
dc(ID) 273
dc(SBC) 2
dc(TGID) 273
dc(TGN) 434
dc(beginTime) 2
dc(c1907466966) 29
dc(c1907466967) 38
dc(c1907466968) 32
dc(c1907466969) 15
dc(c1907466970) 32
dc(c1907466971) 34
dc(c1907466972) 5
dc(c1907466973) 28
dc(c1907466974) 36
dc(c1907466975) 33
dc(c1907466976) 38
dc(c1907466977)
(?P<subname>\\w+_(?<=_).*?(?=\\.)).*" |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}