using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w{8})(\w{8})(\w{4})(\w{8})(\w{39})$";
string input = @"49cd0d18000100000069543ace68000000000000000000000000000000000000000";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}