package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w{8})(\w{8})(\w{4})(\w{8})(\w{39})$`)
var str = `49cd0d18000100000069543ace68000000000000000000000000000000000000000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}