re = /^(\w{8})(\w{8})(\w{4})(\w{8})(\w{39})$/
str = '49cd0d18000100000069543ace68000000000000000000000000000000000000000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end