import Foundation
let pattern = #"^(\w{8})(\w{8})(\w{4})(\w{8})(\w{39})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"49cd0d18000100000069543ace68000000000000000000000000000000000000000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}