const regex = /^(\w{8})(\w{8})(\w{4})(\w{8})(\w{39})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w{8})(\\w{8})(\\w{4})(\\w{8})(\\w{39})$', '')
const str = `49cd0d18000100000069543ace68000000000000000000000000000000000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}