#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[.\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\w+"
Local $sString = "abcd.png" & @CRLF & _
"abcd.mp3" & @CRLF & _
"abcd.mp4" & @CRLF & _
"abcd.wmv" & @CRLF & _
"abcd.mp3" & @CRLF & _
"abcd.jpeg" & @CRLF & _
"abcd.mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")