import re
regex = re.compile(r"(?:[.\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\w+", flags=re.MULTILINE)
test_str = ("abcd.png\n"
"abcd.mp3\n"
"abcd.mp4\n"
"abcd.wmv\n"
"abcd.mp3\n"
"abcd.jpeg\n"
"abcd.mkv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")