const regex = /(?:[.\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[.\\\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\\w+', 'gm')
const str = `abcd.png
abcd.mp3
abcd.mp4
abcd.wmv
abcd.mp3
abcd.jpeg
abcd.mkv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}