using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[.\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\w+";
string input = @"abcd.png
abcd.mp3
abcd.mp4
abcd.wmv
abcd.mp3
abcd.jpeg
abcd.mkv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}