import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[.\\\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\\w+";
final String string = "abcd.png\n"
+ "abcd.mp3\n"
+ "abcd.mp4\n"
+ "abcd.wmv\n"
+ "abcd.mp3\n"
+ "abcd.jpeg\n"
+ "abcd.mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}