$re = '/(?:[.\\\\])(?!(mp3|m4a|wmv|mp4|mkv)$)\w+/m';
$str = 'abcd.png
abcd.mp3
abcd.mp4
abcd.wmv
abcd.mp3
abcd.jpeg
abcd.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);