#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})"
Local $sString = "2015-05-05T13:15:25+02:00" & @CRLF & _
"2015-05-05T13:15:25Z" & @CRLF & _
"2015-05-05T13:15:25-02:00" & @CRLF & _
"2015-05-05T13:15:25.023+02:00" & @CRLF & _
"2015-05-05T13:15:25" & @CRLF & _
"9999-95-23T13:12:76Z" & @CRLF & _
"2015-05-05T13:15:25.123Z" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")