using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})";
string input = @"2015-05-05T13:15:25+02:00
2015-05-05T13:15:25Z
2015-05-05T13:15:25-02:00
2015-05-05T13:15:25.023+02:00
2015-05-05T13:15:25
9999-95-23T13:12:76Z
2015-05-05T13:15:25.123Z
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}