use strict;
my $str = '2015-05-05T13:15:25+02:00
2015-05-05T13:15:25Z
2015-05-05T13:15:25-02:00
2015-05-05T13:15:25.023+02:00
2015-05-05T13:15:25
9999-95-23T13:12:76Z
2015-05-05T13:15:25.123Z
';
my $regex = qr/\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}