// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})").unwrap();
let string = "2015-05-05T13:15:25+02:00
2015-05-05T13:15:25Z
2015-05-05T13:15:25-02:00
2015-05-05T13:15:25.023+02:00
2015-05-05T13:15:25
9999-95-23T13:12:76Z
2015-05-05T13:15:25.123Z
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}