import Foundation
let pattern = #"\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2015-05-05T13:15:25+02:00
2015-05-05T13:15:25Z
2015-05-05T13:15:25-02:00
2015-05-05T13:15:25.023+02:00
2015-05-05T13:15:25
9999-95-23T13:12:76Z
2015-05-05T13:15:25.123Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)