$re = '/\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}([.]\d{1,3})?(Z|[-+]\d{2}:\d{2})/';
$str = '2015-05-05T13:15:25+02:00
2015-05-05T13:15:25Z
2015-05-05T13:15:25-02:00
2015-05-05T13:15:25.023+02:00
2015-05-05T13:15:25
9999-95-23T13:12:76Z
2015-05-05T13:15:25.123Z
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);