using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([^{]+)\s*\{\s*([^}]*?)\s*}";
string input = @"body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: ""wat"";
how: 'bout-that';
}
td
.vanilla {
color: red;
bg: wat;
how: 'bout-that';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}
@media only screen and (max-width: 500px) {
body {
background-color: lightblue;
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}