const regex = /\s*([^{]+)\s*\{\s*([^}]*?)\s*}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([^{]+)\\s*\\{\\s*([^}]*?)\\s*}', 'g')
const str = `body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: "wat";
how: 'bout-that';
}
td
.vanilla {
color: red;
bg: wat;
how: 'bout-that';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}
@media only screen and (max-width: 500px) {
body {
background-color: lightblue;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}