re = /\s*([^{]+)\s*\{\s*([^}]*?)\s*}/
str = 'body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: "wat";
how: \'bout-that\';
}
td
.vanilla {
color: red;
bg: wat;
how: \'bout-that\';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}
@media only screen and (max-width: 500px) {
body {
background-color: lightblue;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end