# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*([^{]+)\s*\{\s*([^}]*?)\s*}"
test_str = ("body {background-color: red; }\n\n"
"td .vanilla {background-color: blue;}\n\n"
"td .vanilla {\n"
" color: red;\n"
" bg: \"wat\";\n"
" how: 'bout-that';\n"
"}\n\n"
"td \n"
".vanilla {\n"
" color: red;\n"
" bg: wat;\n"
" how: 'bout-that';\n"
"}\n\n"
".name { color:green; }\n\n"
".dingus-mcgood{aye:yo;}\n\n"
" .wat{test:me}\n\n"
"#another { key : val ; }\n"
"#another { key : val }\n"
"#another{key:val;}\n\n"
"@media only screen and (max-width: 500px) {\n"
" body {\n"
" background-color: lightblue;\n"
" }\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.